restemplate/indy/debian/rules

152 lines
3.8 KiB
Makefile

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets by Bill Allombert 2001
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
# This has to be exported to make some magic below work.
export DH_OPTIONS
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
OPT+= -O0
else
CFLAGS += -O2
OPT+= -O2
endif
FPCVER=$(shell fpc -iV)
FPCLibPrefix=%{libdir}/fpc/%{FPC_Version}
FPCUnitDir=%{FPCLibPrefix}/units
FPCUnitArcDir=%{FPCUnitDir}/%{CPU_TARGET}-%{_os}
#macros for install file placement
BUILDDIR=$(CURDIR)/debian/indy-fpc/
BUILDINSTPREFIX=$(BUILDDIR)/usr/lib/fpc/${FPCVER}
BUILDINDYSRCDIR=$(CURDIR)/debian/indy-fpc-src/
BUILDINDYSRCINSTALLPREFIX=${BUILDINDYSRCDIR}/usr/share/fpcsrc/packages/extra/indy
configure: configure-stamp
configure-stamp:
dh_testdir
# Add here commands to configure the package.
touch configure-stamp
dh_install
#Architecture
build: build-arch build-indep
build-arch: build-arch-stamp
build-arch-stamp: configure-stamp
# Add here commands to compile the arch part of the package.
$(MAKE)
touch build-arch-stamp
build-indep: build-indep-stamp
build-indep-stamp: configure-stamp
# Add here commands to compile the indep part of the package.
dh_install *.pas indy-fpc-src
dh_install Makefile* indy-fpc-src
dh_install examples indy-fpc-src
#$(MAKE) doc
touch build-indep-stamp
clean:
dh_testdir
dh_testroot
rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
# Add here commands to clean up after the build process.
-$(MAKE) clean
dh_clean
dh_clean ${BUILDINDYSRCINSTALLPREFIX}/*.pas ${BUILDINDYSRCINSTALLPREFIX}/Makefile*
install: install-indep install-arch
install-indep:
dh_testdir
dh_testroot
dh_clean -k -i
#dh_installdirs -i
# Add here commands to install the indep part of the package into
# debian/<package>-doc.
#INSTALLDOC#
mkdir -p ${BUILDINDYSRCINSTALLPREFIX}
cp -r ${CURDIR}/*.pas ${BUILDINDYSRCINSTALLPREFIX}
cp -r ${CURDIR}/Makefile* ${BUILDINDYSRCINSTALLPREFIX}
cp -r ${CURDIR}/examples ${BUILDINDYSRCINSTALLPREFIX}
dh_install -i
install-arch:
dh_testdir
dh_testroot
dh_clean -k -s
dh_installdirs -s
# Add here commands to install the arch part of the package into
# debian/tmp.
FPCVER={fpc}
$(MAKE) install INSTALL_BASEDIR=${BUILDINSTPREFIX}
# $(MAKE) install DESTDIR=$(CURDIR)/debian/indy-fpc
#
dh_install -s
# Must not depend on anything. This is to be called by
# binary-arch/binary-indep
# in another 'make' thread.
binary-common:
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs
dh_installexamples
# dh_installmenu
# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
# dh_installcron
# dh_installinfo
dh_installman
dh_link
dh_strip
dh_compress
dh_fixperms
# dh_perl
# dh_python
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
# Build architecture independant packages using the common target.
binary-indep: build-indep install-indep
$(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
# Build architecture dependant packages using the common target.
binary-arch: build-arch install-arch
$(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
binary: binary-arch binary-indep
.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure